Mail delivery issues

Incident Report for LANDR

Resolved

This incident has been resolved.
Posted Sep 01, 2026 - 17:44 EDT

Update

We are no longer observing email delivery failures. Thank you for your understanding.
Posted Sep 01, 2026 - 15:08 EDT

Update

We are continuing to monitor for any further issues.
Posted Sep 01, 2026 - 14:34 EDT

Monitoring

We're noticing an improvement in email delivery. We keep monitoring the situation.
Posted Sep 01, 2026 - 13:58 EDT

Update

We are continuing to investigate this issue.
Posted Sep 01, 2026 - 11:06 EDT

Investigating

We are observing mail delivery issues related to a third party provider. Emails sent by the platform, including authentication-related emails are currently not being delivered. We are monitoring the situation.
Posted Sep 01, 2026 - 11:06 EDT
This incident affected: Authentication.