Payments issues
Incident Report for
LANDR
Resolved
The issue affecting purchases in Brazil, Chile, Indonesia, and Sweden has been resolved. Purchases should now be processing normally.
We’ll continue to monitor the situation closely to ensure everything remains stable. Thank you for your patience.
Posted
Jan
18
,
2026
-
10:33
EST
Investigating
We’re currently experiencing a temporary issue that may prevent purchases in the following countries: Brazil, Chile, Indonesia, and Sweden.
We’re monitoring the situation and will share updates as they become available.
Posted
Jan
17
,
2026
-
15:52
EST
This incident affected: Billing.
×
Subscribe to Incident
Subscribe to updates for
Payments issues
via . You'll receive .